Day Two of Race Car Work

It Ran!

3y ago
677

Day one ended with the drivetrain barely in place and the wiring harness partially installed. Day two started with me running the engine harness up to the firewall while Alex started to hook up everything to the engine.

Our new engine harness has a bulkhead connector, making pulling the engine much easier.

Our new engine harness has a bulkhead connector, making pulling the engine much easier.

My new harness to the rear of the car run to the fuel pump, and then back to the tail lights.

My new harness to the rear of the car run to the fuel pump, and then back to the tail lights.

Hooked up to the tail lights.

Hooked up to the tail lights.

Once the engine harness and fuel pump was hooked up, we tried to start the car. Unfortunately, it wouldn't start. We quickly discovered that it wasn't getting spark, and started poking at the distributor. Somehow, the two little tabs that index on the camshaft to turn the rotor were completely broken off. Not sure how it happened, but this must have been what killed the engine at the end of our Pittsburgh race last year. After some parts swapping, the engine fired up instantly.

Harness to the front of the car.

Harness to the front of the car.

Unfortunately, our newly rebuilt transmission wouldn't go in to second, so it had to come out to be re-re-built. That's pretty much where we left it. We have about a month until the race. Should be just enough time to get everything ready.

Join In

Comments (2)

2